summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-02-28 10:50:46 -0500
committerWilliam Jon McCann <mccann@jhu.edu>2007-02-28 10:50:46 -0500
commit8b33f57e8cd5f451d55fbb0f9bcc3c119a076326 (patch)
treebeef4220bebc726fca41a6a6e37e5b3a8996ca6e /configure.ac
parent593d2ae454f225c545c35398ddfd2c92389e48a7 (diff)
add framework for backend tools
System dependent tools will be built in subdirectories under tools.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 41403a0..2da5655 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,6 +134,26 @@ AC_SUBST(CONSOLE_KIT_PID_FILE)
AC_DEFINE_UNQUOTED(CONSOLE_KIT_PID_FILE, "$CONSOLE_KIT_PID_FILE", [pid file])
dnl ---------------------------------------------------------------------------
+dnl Figure out what tools backend to build
+dnl ---------------------------------------------------------------------------
+
+CK_BACKEND=""
+case "$host" in
+ *-*-freebsd*)
+ ;;
+ *-*-linux*)
+ CK_BACKEND="linux"
+ ;;
+ *-*-solaris*)
+ ;;
+esac
+
+AM_CONDITIONAL(CK_COMPILE_LINUX, test x$CK_BACKEND = xlinux, [Compiling for Linux])
+AM_CONDITIONAL(CK_COMPILE_FREEBSD, test x$CK_BACKEND = xfreebsd, [Compiling for FreeBSD])
+AM_CONDITIONAL(CK_COMPILE_SOLARIS, test x$CK_BACKEND = xsolaris, [Compiling for Solaris])
+AC_SUBST(CK_BACKEND)
+
+dnl ---------------------------------------------------------------------------
dnl Finish
dnl ---------------------------------------------------------------------------
@@ -207,6 +227,7 @@ AC_OUTPUT([
Makefile
src/Makefile
tools/Makefile
+tools/linux/Makefile
data/Makefile
data/ConsoleKit
])
@@ -229,6 +250,8 @@ echo "
Base libs: ${CONSOLE_KIT_LIBS}
Maintainer mode: ${USE_MAINTAINER_MODE}
+ Backend: ${CK_BACKEND}
+
dbus-1 system.d dir: ${DBUS_SYS_DIR}
"