summaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <mbiebl@gmail.com>2007-12-08 22:50:17 -0500
committerWilliam Jon McCann <mccann@jhu.edu>2007-12-08 22:50:17 -0500
commit751b95f2aa2eb2cea7fe9e0dec0848865d118ad0 (patch)
tree7f6d2f3ea0b405f94f48d30d6af8598d9fe3d0f4 /data/Makefile.am
parenteb610a07a17db29138df50cafa4cf131a645332e (diff)
remove obsolete sysv init script
given that my first patch get's applied, it makes sense to remove the old sysv init script, as it's not really needed anymore. Besides, most distros will not use this init script anyways as they have special policies for their init script and provide their own.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am15
1 files changed, 1 insertions, 14 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 9516c3b..e2a237b 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -6,15 +6,6 @@ dbusconf_DATA = ConsoleKit.conf
seatdir = $(sysconfdir)/ConsoleKit/seats.d
seat_DATA = 00-primary.seat
-SCRIPT_IN_FILES = ConsoleKit.in
-
-# I guess it's Linux-only but that will do for the moment.
-if ! CK_COMPILE_FREEBSD
-initddir=$(sysconfdir)/rc.d/init.d
-initd_SCRIPTS= \
- ConsoleKit \
- $(NULL)
-endif
servicedir = $(datadir)/dbus-1/system-services
service_in_files = org.freedesktop.ConsoleKit.service.in
@@ -23,9 +14,6 @@ service_DATA = $(service_in_files:.service.in=.service)
$(service_DATA): $(service_in_files) Makefile
$(edit) $< >$@
-ConsoleKit: ConsoleKit.in Makefile
- $(edit) $< >$@
-
edit = sed \
-e 's|@sbindir[@]|$(sbindir)|g' \
-e 's|@sysconfdir[@]|$(sysconfdir)|g' \
@@ -35,7 +23,6 @@ edit = sed \
EXTRA_DIST = \
$(dbusconf_DATA) \
$(seat_DATA) \
- $(SCRIPT_IN_FILES) \
$(service_in_files) \
$(NULL)
@@ -43,4 +30,4 @@ MAINTAINERCLEANFILES = \
*~ \
Makefile.in
-CLEANFILES = ConsoleKit $(service_DATA)
+CLEANFILES = $(service_DATA)