summaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <mbiebl@gmail.com>2007-04-02 16:16:16 -0400
committerWilliam Jon McCann <mccann@jhu.edu>2007-04-02 16:16:16 -0400
commitb57d5c11612dbb896c53d65c01104bae586f6e17 (patch)
treeb7063a6133b6e339d38a372b87c00b5b1737fdde /data/Makefile.am
parent86740ea242d0b26758e8a8c43904a0fc88a195f6 (diff)
autoconf fixes, separate pamlibdir variable, path expansion at make time
The attached patch does the following: - Use a separate $pam-module-dir variable for the pam module - Instead of defining a custom $slibdir variable, just use the standard $libdir variable specified by autoconf - Use the standard autoconf $docdir variable (Add AC_PREREQ(2.59) for that). - Drop AS_AC_EXPAND macro and remove AC_DEFINE_UNQUOTED for dir variables. + Build the init script at make time using sed + Use defines in src/Makefile.am to pass the variables to gcc at make time - Consistently use AC_HELP_STRING everywhere - Remove/Replace deprecated macros: + AM_INIT_AUTOMAKE takes the package name and version number from AC_INIT + AM_CONFIG_HEADER -> AC_CONFIG_HEADERS + AC_OUTPUT -> AC_CONFIG_FILES Patch is tested and make distcheck works.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 9c8f0ab..f9216c4 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -9,10 +9,23 @@ initd_SCRIPTS= \
ConsoleKit \
$(NULL)
+
+ConsoleKit: ConsoleKit.in Makefile
+ $(edit) $< >$@
+
+edit = sed \
+ -e 's|@sbindir[@]|$(sbindir)|g' \
+ -e 's|@sysconfdir[@]|$(sysconfdir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
+ -e 's|@CONSOLE_KIT_PID_FILE[@]|$(CONSOLE_KIT_PID_FILE)|g'
+
EXTRA_DIST = \
$(dbusconf_DATA) \
+ $(SCRIPT_IN_FILES) \
$(NULL)
MAINTAINERCLEANFILES = \
*~ \
Makefile.in
+
+CLEANFILES = ConsoleKit