summaryrefslogtreecommitdiffstats
path: root/libck-connector/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-03-13 03:39:52 -0400
committerWilliam Jon McCann <mccann@jhu.edu>2007-03-13 03:39:52 -0400
commit4595ab3d4953d6257a6fedfe5b294df67ff3581f (patch)
tree56796949d8dd86112714c9e95d5afbf6506fa2f2 /libck-connector/Makefile.am
parent29437f4aa9bd1bab54bde41cb1f6301803a2632e (diff)
install the connector into libdir by default
If building the PAM module then it probably should be going into /lib. However, hardcoding /lib makes it very difficult to build as non-root, breaks make distcheck, and probably isn't correct for 64 bit systems. If you are a distro you should probably configure using --libdir=/lib.
Diffstat (limited to 'libck-connector/Makefile.am')
-rw-r--r--libck-connector/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/libck-connector/Makefile.am b/libck-connector/Makefile.am
index 9727175..757c41e 100644
--- a/libck-connector/Makefile.am
+++ b/libck-connector/Makefile.am
@@ -5,11 +5,10 @@ INCLUDES = \
$(LIBDBUS_CFLAGS) \
$(NULL)
-slib_LTLIBRARIES = \
+lib_LTLIBRARIES = \
libck-connector.la \
$(NULL)
-slibdir = /lib
libck_connectorincludedir = $(includedir)/ConsoleKit/ck-connector
libck_connectorinclude_HEADERS = \