summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-10-17 17:09:03 -0400
committerWilliam Jon McCann <mccann@jhu.edu>2007-10-17 17:09:03 -0400
commit1773b5f77b9c575ab8fc3e3d692e8a7056fe2959 (patch)
tree30b8a4f304544637371fbb09acf7c4dead557fb7 /src/Makefile.am
parent0011a7aa94a9dbb00a322a1c08d5ac6a6dfdc21c (diff)
add a basic ck-history command
Refactor some event logging code to share with ck-history. At the moment the command only prints the events.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 54e37cb..3d08222 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,9 +25,15 @@ INCLUDES = \
$(NULL)
noinst_LTLIBRARIES = \
- libck.la \
+ libck.la \
+ libck-event-log.la \
$(NULL)
+libck_event_log_la_SOURCES = \
+ ck-log-event.h \
+ ck-log-event.c \
+ $(NULL)
+
libck_la_SOURCES = \
ck-sysdeps.h \
ck-sysdeps-unix.c \
@@ -122,6 +128,7 @@ EXTRA_console_kit_daemon_SOURCES = \
console_kit_daemon_LDADD = \
$(CONSOLE_KIT_LIBS) \
libck.la \
+ libck-event-log.la \
$(NULL)
noinst_PROGRAMS = \
@@ -138,6 +145,7 @@ test_event_logger_SOURCES = \
test_event_logger_LDADD = \
$(CONSOLE_KIT_LIBS) \
+ libck-event-log.la \
$(NULL)
test_vt_monitor_SOURCES = \