summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-08-17 12:59:41 -0400
committerWilliam Jon McCann <mccann@jhu.edu>2007-08-17 12:59:41 -0400
commit3423ce3039033e8bf54860a2b955fdf8c1f21be7 (patch)
treef9da817b4799d19e28c673e1e26d7a42f94fcde9 /src/Makefile.am
parentbec4b4163ae65fa271845da6b748456346987c26 (diff)
add a vt monitor test, move getfd to sysdeps, add a check for the root user
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 244e39e..a5dc1e6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -91,7 +91,6 @@ console_kit_daemon_SOURCES = \
ck-session.c \
ck-log.h \
ck-log.c \
- getfd.c \
$(BUILT_SOURCES) \
$(NULL)
@@ -115,6 +114,18 @@ console_kit_daemon_LDADD = \
noinst_PROGRAMS = \
test-tty-idle-monitor \
+ test-vt-monitor \
+ $(NULL)
+
+test_vt_monitor_SOURCES = \
+ ck-vt-monitor.h \
+ ck-vt-monitor.c \
+ test-vt-monitor.c \
+ $(NULL)
+
+test_vt_monitor_LDADD = \
+ $(CONSOLE_KIT_LIBS) \
+ libck.la \
$(NULL)
test_tty_idle_monitor_SOURCES = \
@@ -127,6 +138,7 @@ test_tty_idle_monitor_SOURCES = \
test_tty_idle_monitor_LDADD = \
$(CONSOLE_KIT_LIBS) \
+ libck.la \
$(NULL)
EXTRA_DIST = \