summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-08-25 17:08:20 +0100
committerFlorent Thoumie <flz@FreeBSD.org>2007-08-25 17:08:20 +0100
commit342f4d1b60850daad422bd683978a88cb6a7eed7 (patch)
treec027328d454bc357036a239e162095ac2573f567 /src/Makefile.am
parentf19761b0e2e6649836d3514fbd007b9365756f32 (diff)
First attempt a making ConsoleKit work on FreeBSD
- Add some ifdef's to make the code compile. - Add ck-sysdeps-freebsd.c, based on the Linux version, which means it's using linprocfs right now. Signed-off-by: Florent Thoumie <flz@FreeBSD.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a5dc1e6..eee798d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -42,6 +42,11 @@ libck_la_SOURCES += \
ck-sysdeps-solaris.c \
$(NULL)
endif
+if CK_COMPILE_FREEBSD
+libck_la_SOURCES += \
+ ck-sysdeps-freebsd.c \
+ $(NULL)
+endif
EXTRA_libck_la_SOURCES = \
ck-sysdeps-linux.c \