summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-04-05 15:21:14 -0400
committerWilliam Jon McCann <mccann@jhu.edu>2007-04-05 15:21:14 -0400
commite0244a8f6dd0b7f8ebecc6bec52c013ce5286279 (patch)
tree9e890e4d7bba3ed70194c012fccbd159357afa1f /src/Makefile.am
parent33dcd02c399e3255a7a64c1e90b258d79c14f2c4 (diff)
use inotify to detect activity on tty when possible
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 26eb8e7..0977591 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -59,6 +59,9 @@ console_kit_daemon_SOURCES = \
ck-manager.c \
ck-vt-monitor.h \
ck-vt-monitor.c \
+ ck-tty-idle-monitor.h \
+ ck-tty-idle-monitor.c \
+ ck-file-monitor.h \
ck-job.h \
ck-job.c \
ck-seat.h \
@@ -73,10 +76,39 @@ console_kit_daemon_SOURCES = \
$(BUILT_SOURCES) \
$(NULL)
+if ENABLE_INOTIFY
+FILE_MONITOR_BACKEND = ck-file-monitor-inotify.c
+else
+FILE_MONITOR_BACKEND = ck-file-monitor-dummy.c
+endif
+
+console_kit_daemon_SOURCES += $(FILE_MONITOR_BACKEND)
+
+EXTRA_console_kit_daemon_SOURCES = \
+ ck-file-monitor-inotify.c \
+ ck-file-monitor-dummy.c \
+ $(NULL)
+
console_kit_daemon_LDADD = \
$(CONSOLE_KIT_LIBS) \
$(NULL)
+noinst_PROGRAMS = \
+ test-tty-idle-monitor \
+ $(NULL)
+
+test_tty_idle_monitor_SOURCES = \
+ ck-tty-idle-monitor.h \
+ ck-tty-idle-monitor.c \
+ ck-file-monitor.h \
+ $(FILE_MONITOR_BACKEND) \
+ test-tty-idle-monitor.c \
+ $(NULL)
+
+test_tty_idle_monitor_LDADD = \
+ $(CONSOLE_KIT_LIBS) \
+ $(NULL)
+
EXTRA_DIST = \
ck-marshal.list \
ck-manager.xml \