summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2008-07-23 23:22:36 -0400
committerWilliam Jon McCann <jmccann@redhat.com>2008-07-23 23:22:36 -0400
commite54095996b9066120ebf20011eba199d25422c2f (patch)
tree6d88da2ce0137fed1ece3bf610690e66809f76b0 /src/Makefile.am
parent34cefc96f7661ed92927bffa1cf7cbc79a84e5ab (diff)
use spec files directly as introspection xml and try to generate docs on the fly
At one point we had to strip out the docs because dbus-glib didn't support unknown tags. Apparently this is now fixed. Also install the xml to /usr/share/dbus-1/interfaces.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am23
1 files changed, 14 insertions, 9 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b5b8f08..cbe8a09 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -75,12 +75,19 @@ BUILT_SOURCES = \
ck-marshal.h \
$(NULL)
-ck-manager-glue.h: ck-manager.xml Makefile.am
- dbus-binding-tool --prefix=ck_manager --mode=glib-server --output=ck-manager-glue.h ck-manager.xml
-ck-seat-glue.h: ck-seat.xml Makefile.am
- dbus-binding-tool --prefix=ck_seat --mode=glib-server --output=ck-seat-glue.h ck-seat.xml
-ck-session-glue.h: ck-session.xml Makefile.am
- dbus-binding-tool --prefix=ck_session --mode=glib-server --output=ck-session-glue.h ck-session.xml
+dbusifdir = $(datadir)/dbus-1/interfaces
+dbusif_DATA = \
+ org.freedesktop.ConsoleKit.Manager.xml \
+ org.freedesktop.ConsoleKit.Seat.xml \
+ org.freedesktop.ConsoleKit.Session.xml \
+ $(NULL)
+
+ck-manager-glue.h: org.freedesktop.ConsoleKit.Manager.xml Makefile.am
+ dbus-binding-tool --prefix=ck_manager --mode=glib-server --output=ck-manager-glue.h org.freedesktop.ConsoleKit.Manager.xml
+ck-seat-glue.h: org.freedesktop.ConsoleKit.Seat.xml Makefile.am
+ dbus-binding-tool --prefix=ck_seat --mode=glib-server --output=ck-seat-glue.h org.freedesktop.ConsoleKit.Seat.xml
+ck-session-glue.h: org.freedesktop.ConsoleKit.Session.xml Makefile.am
+ dbus-binding-tool --prefix=ck_session --mode=glib-server --output=ck-session-glue.h org.freedesktop.ConsoleKit.Session.xml
ck-marshal.c: ck-marshal.list
echo "#include \"ck-marshal.h\"" > $@ && \
@@ -183,9 +190,7 @@ test_tty_idle_monitor_LDADD = \
EXTRA_DIST = \
ck-marshal.list \
- ck-manager.xml \
- ck-seat.xml \
- ck-session.xml \
+ $(dbusif_DATA) \
valgrind.sh \
test-open-session \
test-open-session-with-parameters \