summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..6f96464
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,37 @@
+NULL =
+
+SPEC_XML_FILES = \
+ ConsoleKit.xml \
+ ck-introduction.xml \
+ ck-dbus-manager.xml \
+ ck-dbus-seat.xml \
+ ck-dbus-session.xml \
+ $(NULL)
+
+if DOCBOOK_DOCS_ENABLED
+
+htmldocdir = $(DOCDIR)/spec
+htmldoc_DATA = ConsoleKit.html
+
+ConsoleKit.html : $(SPEC_XML_FILES)
+ $(XMLTO) html-nochunks -m config.xsl ConsoleKit.xml
+
+endif # DOCBOOK_DOCS_ENABLED
+
+EXTRA_DIST = \
+ ConsoleKit.html \
+ ConsoleKit.xml.in \
+ config.xsl \
+ docbook.css \
+ $(SPEC_XML_FILES)
+ $(NULL)
+
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in \
+ $(NULL)
+
+clean-local:
+ rm -f *~
+ rm -f ConsoleKit.html