summaryrefslogtreecommitdiffstats
path: root/tools/linux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/linux/Makefile.am')
-rw-r--r--tools/linux/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/tools/linux/Makefile.am b/tools/linux/Makefile.am
new file mode 100644
index 0000000..5091efe
--- /dev/null
+++ b/tools/linux/Makefile.am
@@ -0,0 +1,33 @@
+## We require new-style dependency handling.
+AUTOMAKE_OPTIONS = 1.7
+
+NULL =
+
+SUBDIRS = \
+ $(NULL)
+
+INCLUDES = \
+ -I. \
+ -I$(srcdir) \
+ $(CONSOLE_KIT_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS) \
+ -DPREFIX=\""$(prefix)"\" \
+ -DBINDIR=\""$(bindir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ $(WARN_CFLAGS) \
+ $(DEBUG_CFLAGS) \
+ $(TOOLS_CFLAGS) \
+ $(NULL)
+
+libexec_PROGRAMS = \
+ $(NULL)
+
+EXTRA_DIST = \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ Makefile.in