summaryrefslogtreecommitdiffstats
path: root/conf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'conf/Makefile.am')
-rw-r--r--conf/Makefile.am46
1 files changed, 0 insertions, 46 deletions
diff --git a/conf/Makefile.am b/conf/Makefile.am
deleted file mode 100644
index 789350f..0000000
--- a/conf/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
-# $Id$
-
-# This file is part of waproamd.
-#
-# waproamd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# waproamd is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with waproamd; if not, write to the Free Software Foundation,
-# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-
-EXTRA_DIST = waproamd.init.in waproamd.conf default.in
-
-if BUILD_WAPROAMD
-
-noinst_DATA = waproamd.init waproamd.conf default
-
-CLEANFILES = waproamd.init default
-
-waproamd.init: waproamd.init.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' $< > $@
- chmod 755 $@
-
-default: default.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' $< > $@
- chmod 755 $@
-
-install-data-local: waproamd.init
- $(INSTALL) -b -D -m755 waproamd.init ${DESTDIR}/${sysconfdir}/init.d/waproamd
- $(INSTALL) -b -D -m644 $(srcdir)/waproamd.conf ${DESTDIR}/${sysconfdir}/waproamd/waproamd.conf
- mkdir -p ${DESTDIR}/${sysconfdir}/waproamd/keys
- $(INSTALL) -D -m755 default ${DESTDIR}/${sysconfdir}/waproamd/scripts/default
-
-uninstall-local:
- rmdir ${DESTDIR}/${sysconfdir}/waproamd/keys
- rm -f ${DESTDIR}/${sysconfdir}/init.d/waproamd ${DESTDIR}/${sysconfdir}/waproamd/waproamd.conf
- rm -f ${DESTDIR}/${sysconfdir}/waproamd/scripts/default
-
-endif