summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac52
1 files changed, 10 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 99bce11..40aed44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,25 +3,25 @@
# $Id$
-# This file is part of waproamd.
+# This file is part of aeswepd.
#
-# waproamd is free software; you can redistribute it and/or modify it
+# aeswepd is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
-# waproamd is distributed in the hope that it will be useful, but
+# aeswepd is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with waproamd; if not, write to the Free Software Foundation,
+# along with aeswepd; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
AC_PREREQ(2.57)
-AC_INIT([waproamd], [0.2], [mzjncebnzq (at) 0pointer (dot) de])
-AC_CONFIG_SRCDIR([src/waproamd.c])
+AC_INIT([aeswepd], [0.2], [mznrfjrcq (at) 0pointer (dot) de])
+AC_CONFIG_SRCDIR([src/aeswepd.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
@@ -30,14 +30,14 @@ AC_PROG_CC
AC_PROG_LN_S
AC_PROG_MAKE_SET
-AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/waproamd/])
+AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/aeswepd/])
# If using GCC specifiy some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall"
fi
-if test -d /usr/local/stow ; then
+if test -d /usr/local/stow && type -p stow > /dev/null ; then
AC_MSG_NOTICE([*** Found /usr/local/stow: installing to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
AC_PREFIX_DEFAULT([/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}])
fi
@@ -48,7 +48,7 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS([fcntl.h limits.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h unistd.h])
AC_CHECK_LIB([daemon], [daemon_fork],, [AC_MSG_ERROR([*** Sorry, you have to install libdaemon ***])])
-AC_CHECK_LIB([mcrypt], [mcrypt_module_open], [MCRYPT=1 AC_DEFINE(HAVE_MCRYPT, 1, [libmcrypt available])], [MCRYPT=0])
+AC_CHECK_LIB([mcrypt], [mcrypt_module_open], [AC_DEFINE(HAVE_MCRYPT, 1, [libmcrypt available])], [AC_MSG_ERROR([*** Sorry, you have to install libmcrypt or use --disable-aeswepd ***])])
AC_C_CONST
AC_TYPE_MODE_T
@@ -101,37 +101,5 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
-# Build aeswepd?
-AC_ARG_ENABLE(aeswepd,
- AC_HELP_STRING([--disable-aeswepd], [Disable building of aeswepd]),
-[case "${enableval}" in
- yes) aeswepd=yes ;;
- no) aeswepd=no ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --disable-aeswepd]) ;;
-esac], [aeswepd=yes])
-
-# Build waproamd?
-AC_ARG_ENABLE(waproamd,
- AC_HELP_STRING([--disable-waproamd], [Disable building of waproamd]),
-[case "${enableval}" in
- yes) waproamd=yes ;;
- no) waproamd=no ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --disable-waproamd]) ;;
-esac], [waproamd=yes])
-
-if test x$aeswepd = xno && test x$waproamd = xno ; then
- AC_MSG_ERROR([*** If you build neither aeswepd nor waproamd, nothing gets built ***])
-fi
-
-if test x$aeswepd = xyes && test x$MCRYPT != x1 ; then
- AC_MSG_ERROR([*** Sorry, you have to install libmcrypt or use --disable-aeswepd ***])
-fi
-
-AM_CONDITIONAL([BUILD_AESWEPD], [test "x$aeswepd" = xyes])
-AM_CONDITIONAL([BUILD_WAPROAMD], [test "x$waproamd" = xyes])
-
-AC_CONFIG_FILES([src/Makefile Makefile conf/Makefile doc/Makefile]) # man/Makefile doc/Makefile doc/README.html])
+AC_CONFIG_FILES([src/Makefile Makefile doc/Makefile]) # man/Makefile doc/Makefile doc/README.html])
AC_OUTPUT
-
-AC_MSG_NOTICE([*** aeswepd is built: $aeswepd ***])
-AC_MSG_NOTICE([*** waproamd is built: $waproamd ***])