summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac62
1 files changed, 58 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 76c0677..60f7381 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-# $Id: Makefile.am 22 2003-06-15 16:36:33Z lennart $
+# $Id$
# This file is part of waproamd.
#
@@ -27,17 +27,39 @@ AM_INIT_AUTOMAKE([foreign -Wall])
AM_MAINTAINER_MODE
# Checks for programs.
-AC_PROG_CXX
AC_PROG_CC
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
# If using GCC specifiy some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall"
fi
+if test -d /usr/local/stow ; then
+ AC_MSG_NOTICE([*** Found /usr/local/stow: installing to /usr/local/stow/waproamd-$VERSION *** ])
+ AC_PREFIX_DEFAULT([/usr/local/stow/waproamd-$VERSION])
+fi
+
# Checks for libraries.
+AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([fcntl.h limits.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h unistd.h])
+
AC_CHECK_LIB([daemon], [daemon_fork],, [AC_MSG_ERROR([*** Sorry, you have to install libdaemon ***])])
-AC_CHECK_LIB([mcrypt], [mcrypt_module_open],, [AC_MSG_ERROR([*** Sorry, you have to install libmcrypt ***])])
+AC_CHECK_LIB([mcrypt], [mcrypt_module_open], [MCRYPT=1 AC_DEFINE(HAVE_MCRYPT, 1, [libmcrypt available])], [MCRYPT=0])
+
+AC_C_CONST
+AC_TYPE_MODE_T
+AC_TYPE_PID_T
+AC_HEADER_TIME
+
+AC_FUNC_FORK
+AC_PROG_GCC_TRADITIONAL
+AC_FUNC_MALLOC
+AC_FUNC_MEMCMP
+AC_FUNC_SELECT_ARGTYPES
+AC_CHECK_FUNCS([dup2 ftruncate memset select setenv socket strchr strcspn strdup strerror strrchr])
# LYNX documentation generation
AC_ARG_ENABLE(lynx,
@@ -78,5 +100,37 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
-AC_CONFIG_FILES([src/Makefile Makefile]) # man/Makefile conf/Makefile doc/Makefile doc/README.html patches/Makefile waproamd.spec])
+# Build aeswepd?
+AC_ARG_ENABLE(aeswepd,
+ AC_HELP_STRING([--disable-aeswepd], [Disable building of aeswepd]),
+[case "${enableval}" in
+ yes) aeswepd=yes ;;
+ no) aeswepd=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --disable-aeswepd]) ;;
+esac], [aeswepd=yes])
+
+# Build waproamd?
+AC_ARG_ENABLE(waproamd,
+ AC_HELP_STRING([--disable-waproamd], [Disable building of waproamd]),
+[case "${enableval}" in
+ yes) waproamd=yes ;;
+ no) waproamd=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --disable-waproamd]) ;;
+esac], [waproamd=yes])
+
+if test x$aeswepd = xno && test x$waproamd = xno ; then
+ AC_MSG_ERROR([*** If you build neither aeswepd nor waproamd, nothing gets built ***])
+fi
+
+if test x$aeswepd = xyes && test x$MCRYPT != x1 ; then
+ AC_MSG_ERROR([*** Sorry, you have to install libmcrypt or use --disable-aeswepd ***])
+fi
+
+AM_CONDITIONAL([BUILD_AESWEPD], [test "x$aeswepd" = xyes])
+AM_CONDITIONAL([BUILD_WAPROAMD], [test "x$waproamd" = xyes])
+
+AC_CONFIG_FILES([src/Makefile Makefile conf/Makefile conf/scripts/Makefile doc/Makefile]) # man/Makefile doc/Makefile doc/README.html])
AC_OUTPUT
+
+AC_MSG_NOTICE([*** aeswepd is built: $aeswepd ***])
+AC_MSG_NOTICE([*** waproamd is built: $waproamd ***])