summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..11ac17d
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,40 @@
+# $Id$
+
+# This file is part of aeswepd.
+#
+# aeswepd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# aeswepd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with aeswepd; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+man_MANS = aeswepd.8 aeswepls.8
+
+noinst_DATA = aeswepd.8.xml
+
+EXTRA_DIST = $(man_MANS) aeswepd.8.xml.in man.css man.xsl
+
+CLEANFILES = aeswepd.8.xml aeswepls.8
+
+aeswepd.8.xml: aeswepd.8.xml.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+if USE_XMLTOMAN
+
+CLEANFILES += $(man_MANS)
+
+aeswepd.8: aeswepd.8.xml Makefile
+ xmltoman $< > $@
+
+endif
+
+aeswepls.8: aeswepd.8
+ ln -sf $< $@