summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am31
1 files changed, 5 insertions, 26 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3c059ec..ce00817 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,42 +1,22 @@
# $Id$
-# This file is part of waproamd.
+# This file is part of aeswepd.
#
-# waproamd is free software; you can redistribute it and/or modify it
+# aeswepd is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
-# waproamd is distributed in the hope that it will be useful, but
+# aeswepd is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with waproamd; if not, write to the Free Software Foundation,
+# along with aeswepd; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-AM_CFLAGS = -DSYSCONFDIR="\"$(sysconfdir)\""
-
-sbin_PROGRAMS =
-
-if BUILD_WAPROAMD
-sbin_PROGRAMS += waproamd
-
-waproamd_SOURCES = waproamd.c waproamd.h \
- interface.c interface.h \
- iwapi.c iwapi.h \
- util.c util.h \
- exec.c exec.h \
- nlapi.c nlapi.h \
- assocwatch.c assocwatch.h \
- ifmonitor.c ifmonitor.h \
- wireless.h wireless.15.h \
- netlink.h rtnetlink.h
-endif
-
-if BUILD_AESWEPD
-sbin_PROGRAMS += aeswepd
+sbin_PROGRAMS = aeswepd
aeswepd_SOURCES = aeswepd.c aeswepd.h \
aes.c aes.h \
@@ -50,7 +30,6 @@ aeswepd_LDADD = -lmcrypt
install-exec-hook:
cd $(DESTDIR)/$(sbindir) && ln -sf aeswepd aeswepls
-endif
svnkeywords:
svn propset svn:keywords Id *.c *.h Makefile.am