summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am51
1 files changed, 48 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a55c459..1080a15 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,51 @@
+# $Id$
+
+# This file is part of waproamd.
+#
+# waproamd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# waproamd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with waproamd; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
AM_CFLAGS = -DSYSCONFDIR="\"$(sysconfdir)\""
-sbin_PROGRAMS = waproamd aeswepd
+sbin_PROGRAMS =
+
+if BUILD_WAPROAMD
+sbin_PROGRAMS += waproamd
+
+waproamd_SOURCES = waproamd.c waproamd.h \
+ interface.c interface.h \
+ iwapi.c iwapi.h \
+ util.c util.h \
+ exec.c exec.h \
+ nlapi.c nlapi.h \
+ assocwatch.c assocwatch.h \
+ ifmonitor.c ifmonitor.h \
+ wireless.h wireless.15.h
+endif
+
+if BUILD_AESWEPD
+sbin_PROGRAMS += aeswepd
+
+aeswepd_SOURCES = aeswepd.c aeswepd.h \
+ aes.c aes.h \
+ interface.c interface.h \
+ iwkey.c iwkey.h \
+ util.c util.h \
+ wireless.h wireless.15.h
+
+aeswepd_LDADD = -lmcrypt
-aeswepd_SOURCES = aeswepd.c aeswepd.h aes.c aes.h interface.c interface.h iwkey.c iwkey.h util.c util.h
-waproamd_SOURCES = waproamd.c interface.c interface.h iwapi.c iwapi.h util.c util.h exec.c exec.h nlapi.c nlapi.h assocwatch.c assocwatch.h ifmonitor.c ifmonitor.h
+install-exec-hook:
+ cd $(DESTDIR)/$(sbindir) && ln -sf aeswepd aeswepls
+endif