summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2006-04-06 17:37:13 +0200
committerTakashi Iwai <tiwai@suse.de>2006-04-06 17:37:13 +0200
commit74bdac50b257b986cea38a2c08134c430fc5654f (patch)
tree5e30207026f4f777edb21f6bd729087f5e0a3c4c /Makefile.am
parent423a6f3c7be331984ec74587bf278204d19a4467 (diff)
Add samplerate rate converter plugin
Added a rate converter pluging using libsamplerate. The plugin is built only when libsamplerate is detected by configure. See doc/samplerate.txt for usage. This plugin is released under GPL (to follow the license of libsamplerate), not LGPL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5de61a3..6b9e37a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,9 +4,12 @@ endif
if HAVE_POLYP
POLYPDIR = polyp
endif
+if HAVE_SAMPLERATE
+SAMPLERATEDIR = rate
+endif
-SUBDIRS = oss mix $(JACKDIR) $(POLYPDIR) doc
-EXTRA_DIST = cvscompile version
+SUBDIRS = oss mix $(JACKDIR) $(POLYPDIR) $(SAMPLERATEDIR) doc
+EXTRA_DIST = cvscompile version COPYING.GPL
AUTOMAKE_OPTIONS = foreign
dist-hook: