summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2007-05-07 17:38:22 +0200
committerTakashi Iwai <tiwai@suse.de>2007-05-07 17:38:22 +0200
commit7244955fe9ad9cbbc8f16c927da4d9bd4e5d1b20 (patch)
treed4b8bc6c80879e737261e10567b6928d4e67f2f9 /configure.in
parent7d12beb1332bf07e17eb8df412cd20dbbbf62c22 (diff)
Fix plugindir config setting
Fixed plugindir config setting when no option was given. Also fixed an obvious typo.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 88484b1..9313b0f 100644
--- a/configure.in
+++ b/configure.in
@@ -53,6 +53,7 @@ CFLAGS="$CFLAGS_saved"
LDFLAGS="$LDFLAGS_saved"
dnl ALSA plugin directory
+test "x$prefix" = xNONE && prefix=$ac_default_prefix
test "x$exec_prefix" = xNONE && exec_prefix=$prefix
AC_ARG_WITH(plugindir,
@@ -67,7 +68,7 @@ if test -z "$plugindir"; then
esac
plugindir="$dir/alsa-lib"
fi
-AC_DEFINE_UNQUOTED(ALSA_PLUGIN_DIR, "plugindir", [directory containing ALSA add-on modules])
+AC_DEFINE_UNQUOTED(ALSA_PLUGIN_DIR, "$plugindir", [directory containing ALSA add-on modules])
ALSA_PLUGIN_DIR="$plugindir"
AC_SUBST(ALSA_PLUGIN_DIR)