summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEduardo Valentin <eduardo.valentin@indt.org.br>2006-11-06 14:32:59 +0100
committerTakashi Iwai <tiwai@suse.de>2006-11-06 14:32:59 +0100
commit8428de6faa31639a5ff7a53c9126f31592077de5 (patch)
tree9f2576847c1e473b7653779deae58afff7d8ff0e /configure.in
parentec9c86f8c1528765dc933ff09d74ae1b1408a7b4 (diff)
Alsa support for Maemo SDK (n770): Build configuration
This patch file changes the build configuration files to add alsa-dsp plugin to communicate with n770 system. Signed-off-by: Eduardo Valentin <eduardo.valentin@indt.org.br>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3c8a137..4465d8f 100644
--- a/configure.in
+++ b/configure.in
@@ -3,6 +3,8 @@ AC_INIT(oss/pcm_oss.c)
AM_INIT_AUTOMAKE(alsa-plugins, 1.0.13)
AC_PREFIX_DEFAULT(/usr)
+AC_CONFIG_HEADERS(config.h)
+
AC_PROG_CC
AC_PROG_INSTALL
AC_DISABLE_STATIC
@@ -22,6 +24,13 @@ AM_CONDITIONAL(HAVE_PULSE, test x$HAVE_PULSE = xyes)
PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
AM_CONDITIONAL(HAVE_SAMPLERATE, test x$HAVE_SAMPLERATE = xyes)
+PKG_CHECK_MODULES(DBUS, [dbus-1], [HAVE_DBUS=yes], [HAVE_DBUS=no])
+AM_CONDITIONAL(HAVE_DBUS, test x$HAVE_DBUS = xyes)
+
+if test "$HAVE_DBUS" = "yes"; then
+ AC_DEFINE(USE_RESOURCE_MANAGER, 1,"Use dbus server as a resouce manager")
+fi
+
AC_ARG_WITH([avcodec-includedir],
[--with-avcodec-includedir=dir AVcodec include directory],
[AVCODEC_CFLAGS="-I$withval"], [AVCODEC_CFLAGS=""])
@@ -53,5 +62,6 @@ AC_OUTPUT([
mix/Makefile
rate/Makefile
a52/Makefile
+ maemo/Makefile
doc/Makefile
])