summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-11-13 13:10:31 +0100
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-11-13 13:27:56 +0100
commit8e4cd0e52ceda7acbf52616beadf7a355208400e (patch)
tree18b621b9f113e56b1638b7bf39ee216b7135edb9 /configure.in
parent0f30b30384caa59b5d6a34ec4cf493230c3fa096 (diff)
Allow opt-out from jack, pulseaudio and avcodec dependencies.
Without this patch the jack, pulseaudio and avcodec discovery was "automagic", without a way for the user to disable the relative plugins if the dependencies are installed but the plugin is unwanted. This patch does not change the default behaviour but allows to opt-out from the plugins by passing the relative --without option at ./configure time. Signed-off-by: Diego 'Flameeyes' Pettenò <flameeyes@gmail.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 26 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 9efb890..4b5b278 100644
--- a/configure.in
+++ b/configure.in
@@ -15,13 +15,28 @@ PKG_CHECK_MODULES(ALSA, alsa >= 1.0.11)
AC_CHECK_LIB(asound, snd_pcm_ioplug_create,,
AC_ERROR([*** libasound has no external plugin SDK]), -ldl)
-PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
+AC_ARG_ENABLE([jack],
+ AS_HELP_STRING([--disable-jack], [Disable building of JACK plugin]))
+
+if test "x$enable_jack" != "xno"; then
+ PKG_CHECK_MODULES(JACK, jack >= 0.98, [HAVE_JACK=yes], [HAVE_JACK=no])
+fi
AM_CONDITIONAL(HAVE_JACK, test x$HAVE_JACK = xyes)
-PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
+AC_ARG_ENABLE([pulseaudio],
+ AS_HELP_STRING([--disable-pulseaudio], [Disable building of pulseaudio plugin]))
+
+if test "x$enable_pulseaudio" != "xno"; then
+ PKG_CHECK_MODULES(pulseaudio, [libpulse >= 0.9.2], [HAVE_PULSE=yes], [HAVE_PULSE=no])
+fi
AM_CONDITIONAL(HAVE_PULSE, test x$HAVE_PULSE = xyes)
-PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
+AC_ARG_ENABLE([samplerate],
+ AS_HELP_STRING([--disable-samplerate], [Disable building of samplerate plugin]))
+
+if test "x$enable_samplerate" != "xno"; then
+ PKG_CHECK_MODULES(samplerate, [samplerate], [HAVE_SAMPLERATE=yes], [HAVE_SAMPLERATE=no])
+fi
AM_CONDITIONAL(HAVE_SAMPLERATE, test x$HAVE_SAMPLERATE = xyes)
AC_ARG_ENABLE([maemo-plugin],
@@ -45,8 +60,14 @@ if test "$use_maemo_rm" = "yes"; then
fi
fi
-PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
-if test "$HAVE_AVCODEC" != "yes"; then
+AC_ARG_ENABLE([avcodec],
+ AS_HELP_STRING([--disable-avcodec], [Don't build plugins depending on avcodec (a52)]))
+
+if test "x$enable_avcodec" != "xno"; then
+ PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
+fi
+
+if test "x$HAVE_AVCODEC" = "xno"; then
AC_ARG_WITH([avcodec-includedir],
AS_HELP_STRING([--with-avcodec-includedir=dir],
[AVcodec include directory]),