summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2009-01-21 16:53:36 +0100
committerTakashi Iwai <tiwai@suse.de>2009-01-21 16:53:36 +0100
commitba7cd8e0a04798479f851741ec29fef97889aa39 (patch)
treecb131bbf756367f119bc6333e83e60b9abb3ad50 /configure.in
parentc547b535a20a0909c17cb6dd14e5e364b2ae0fe9 (diff)
Fix build of pph plugin with speex-1.2rc1
The resampler code is moved to libspeexdsp instead of libspeex. Signed-off-by: Takashi Iwai <tiwai@suse.de>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 837934f..ce95b5d 100644
--- a/configure.in
+++ b/configure.in
@@ -106,16 +106,18 @@ AC_SUBST(AVCODEC_CFLAGS)
AC_SUBST(AVCODEC_LIBS)
AC_SUBST(AVCODEC_HEADER)
-USE_LIBSPEEX=""
+PKG_CHECK_MODULES(speexdsp, [speexdsp >= 1.2], [HAVE_SPEEXDSP="yes"], [HAVE_SPEEXDSP=""])
+AM_CONDITIONAL(HAVE_SPEEXDSP, test "$HAVE_SPEEXDSP" = "yes")
+
AC_ARG_WITH([speex],
AS_HELP_STRING([--with-speex={builtin|lib|no}],
[build speex resampler (built-in code, link with external lib, or no build)]),
[PPH=$withval], [PPH="lib"])
+USE_LIBSPEEX=""
if test "$PPH" = "lib"; then
- PKG_CHECK_MODULES(speex, [speex >= 1.2], [USE_LIBSPEEX="yes"], [USE_LIBSPEEX=""])
- if test "$USE_LIBSPEEX" = "yes"; then
- AC_CHECK_LIB([speex], [speex_resampler_init],
+ if test "$HAVE_SPEEXDSP" = "yes"; then
+ AC_CHECK_LIB([speexdsp], [speex_resampler_init],
[USE_LIBSPEEX="yes"], [USE_LIBSPEEX=""])
fi
if test "$USE_LIBSPEEX" = "yes"; then
@@ -197,6 +199,6 @@ if test "$HAVE_AVCODEC" = "yes"; then
fi
echo "Speex rate plugin: $PPH"
if test "$PPH" = "lib"; then
- echo " speex_CFLAGS: $speex_CFLAGS"
- echo " speex_LIBS: $speex_LIBS"
+ echo " speexdsp_CFLAGS: $speexdsp_CFLAGS"
+ echo " speexdsp_LIBS: $speexdsp_LIBS"
fi