summaryrefslogtreecommitdiffstats
path: root/pph/Makefile.am
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2007-02-22 13:18:07 +0100
committerTakashi Iwai <tiwai@suse.de>2007-02-22 13:18:07 +0100
commit36ccb62d45d6c1192e2dc01ac639e6debc585f00 (patch)
tree3cf5dcea69b2c69e20cc7c09047923fa6ba9ea47 /pph/Makefile.am
parentee123ac93ea59d11e7d3c48aed9cf88d1a5de431 (diff)
Add rate resampler plugin based on speex
Added another rate resampler plugin based on speex code. Light weight and much better quality. From: Jean-Marc Valin <jean-marc.valin@usherbrooke.ca>
Diffstat (limited to 'pph/Makefile.am')
-rw-r--r--pph/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/pph/Makefile.am b/pph/Makefile.am
new file mode 100644
index 0000000..d695ef6
--- /dev/null
+++ b/pph/Makefile.am
@@ -0,0 +1,19 @@
+asound_module_rate_speexrate_LTLIBRARIES = libasound_module_rate_speexrate.la
+
+asound_module_rate_speexratedir = $(libdir)/alsa-lib
+
+AM_CFLAGS = -DOUTSIDE_SPEEX -Wall -g @ALSA_CFLAGS@
+AM_LDFLAGS = -module -avoid-version -export-dynamic
+
+libasound_module_rate_speexrate_la_SOURCES = rate_speexrate.c resample.c
+libasound_module_rate_speexrate_la_LIBADD = @ALSA_LIBS@
+
+install-exec-hook:
+ rm -f $(DESTDIR)$(libdir)/alsa-lib/libasound_module_rate_speexrate_*.so
+ $(LN_S) libasound_module_rate_speexrate.so $(DESTDIR)$(libdir)/alsa-lib/libasound_module_rate_speexrate_best.so
+ $(LN_S) libasound_module_rate_speexrate.so $(DESTDIR)$(libdir)/alsa-lib/libasound_module_rate_speexrate_medium.so
+
+uninstall-hook:
+ rm -f $(DESTDIR)$(libdir)/alsa-lib/libasound_module_rate_speexrate_*.so
+
+noinst_HEADERS = speex_resampler.h