summaryrefslogtreecommitdiffstats
path: root/maemo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'maemo/Makefile.am')
-rw-r--r--maemo/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/maemo/Makefile.am b/maemo/Makefile.am
index 124d17f..47b4548 100644
--- a/maemo/Makefile.am
+++ b/maemo/Makefile.am
@@ -4,14 +4,14 @@ asound_module_ctl_dsp_ctl_LTLIBRARIES = libasound_module_ctl_dsp_ctl.la
asound_module_pcm_alsa_dspdir = @ALSA_PLUGIN_DIR@
asound_module_ctl_dsp_ctldir = @ALSA_PLUGIN_DIR@
-AM_CFLAGS = -Wall -fPIC -DPIC -O2 @ALSA_CFLAGS@ $(DBUS_CFLAGS)
-AM_LDFLAGS = -shared -lm -ldl -lpthread -module -avoid-version -export-dynamic -no-undefined $(LDFLAGS_NOUNDEFINED)
+AM_CFLAGS = -Wall -O2 @ALSA_CFLAGS@ $(DBUS_CFLAGS)
+AM_LDFLAGS = -module -avoid-version -export-dynamic -no-undefined $(LDFLAGS_NOUNDEFINED)
libasound_module_pcm_alsa_dsp_la_SOURCES = dsp-protocol.c alsa-dsp.c
-libasound_module_pcm_alsa_dsp_la_LIBADD = @ALSA_LIBS@ $(DBUS_LIBS)
+libasound_module_pcm_alsa_dsp_la_LIBADD = @ALSA_LIBS@ $(DBUS_LIBS) -lm -lpthread
libasound_module_ctl_dsp_ctl_la_SOURCES = dsp-protocol.c dsp-ctl.c
-libasound_module_ctl_dsp_ctl_la_LIBADD = @ALSA_LIBS@ $(DBUS_LIBS)
+libasound_module_ctl_dsp_ctl_la_LIBADD = @ALSA_LIBS@ $(DBUS_LIBS) -lm -lpthread
noinst_HEADERS = constants.h debug.h dsp-protocol.h list.h reporting.h \
types.h