summaryrefslogtreecommitdiffstats
path: root/speex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'speex/Makefile.am')
-rw-r--r--speex/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/speex/Makefile.am b/speex/Makefile.am
new file mode 100644
index 0000000..7d84190
--- /dev/null
+++ b/speex/Makefile.am
@@ -0,0 +1,9 @@
+asound_module_pcm_speex_LTLIBRARIES = libasound_module_pcm_speex.la
+
+asound_module_pcm_speexdir = @ALSA_PLUGIN_DIR@
+
+AM_CFLAGS = -Wall -g @ALSA_CFLAGS@ @speexdsp_CFLAGS@
+AM_LDFLAGS = -module -avoid-version -export-dynamic -no-undefined $(LDFLAGS_NOUNDEFINED)
+
+libasound_module_pcm_speex_la_SOURCES = pcm_speex.c
+libasound_module_pcm_speex_la_LIBADD = @ALSA_LIBS@ @speexdsp_LIBS@