summaryrefslogtreecommitdiffstats
path: root/avahi-autoipd/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-08-31 19:48:42 +0000
committerLennart Poettering <lennart@poettering.net>2006-08-31 19:48:42 +0000
commit7bf6b7b95b7c3327000794a24e104242598a9f3f (patch)
treed2e6c8597febe4a21019a04906a098e2be9d5c34 /avahi-autoipd/Makefile.am
parent9d709a294b81066a0942a7a642df1b3d4940ad26 (diff)
add support for interface configuration with user supplied event script
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1301 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-autoipd/Makefile.am')
-rw-r--r--avahi-autoipd/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/avahi-autoipd/Makefile.am b/avahi-autoipd/Makefile.am
index c553470..3a6bb2a 100644
--- a/avahi-autoipd/Makefile.am
+++ b/avahi-autoipd/Makefile.am
@@ -20,13 +20,15 @@
if ENABLE_AUTOIPD
if HAVE_LIBDAEMON
+pkgsysconfdir=$(sysconfdir)/avahi
+
AM_CFLAGS= \
-I$(top_srcdir)
# This cool debug trap works on i386/gcc only
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")' \
-DAVAHI_RUNTIME_DIR=\"$(avahi_runtime_dir)/\" \
- -DAVAHI_DNSCONF_SCRIPT=\"$(pkgsysconfdir)/avahi-autoipd.action\"
+ -DAVAHI_IPCONF_SCRIPT=\"$(pkgsysconfdir)/avahi-autoipd.action\"
sbin_PROGRAMS = avahi-autoipd