summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-12-16 20:23:22 +0000
committerLennart Poettering <lennart@poettering.net>2007-12-16 20:23:22 +0000
commit0cbfefdb155c5b79f63ebb19196e783c4cb48afc (patch)
tree869843b7b660aad627207ece7987344897b3d6d3 /avahi-daemon/Makefile.am
parent56a980b3e895c22ad9870a7de29b66f922e468f1 (diff)
Allow compilation against bsdxml instead of Expat. Patch from zml. (Closes #159)
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1585 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 2bb2325..622b4de 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -23,7 +23,7 @@ AM_CFLAGS=-I$(top_srcdir)
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
if HAVE_LIBDAEMON
-if HAVE_EXPAT
+if HAVE_XML
pkgsysconfdir=$(sysconfdir)/avahi
servicedir=$(pkgsysconfdir)/services
@@ -56,8 +56,8 @@ avahi_daemon_SOURCES = \
../avahi-client/check-nss.c \
inotify-nosys.h
-avahi_daemon_CFLAGS = $(AM_CFLAGS) $(LIBDAEMON_CFLAGS)
-avahi_daemon_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-core/libavahi-core.la $(LIBDAEMON_LIBS) -lexpat
+avahi_daemon_CFLAGS = $(AM_CFLAGS) $(LIBDAEMON_CFLAGS) $(XML_CFLAGS)
+avahi_daemon_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-core/libavahi-core.la $(LIBDAEMON_LIBS) $(XML_LIBS)
ini_file_parser_test_SOURCES = \
ini-file-parser.c ini-file-parser.h \