summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-06-02 04:37:40 +0200
committerLennart Poettering <lennart@poettering.net>2010-06-25 00:59:31 +0200
commit238909aaff10489fe538c8c54e3f82fe8a54b849 (patch)
treeafe8cb2df6318fcc1c949ddc8284450a6c8fc9d4 /avahi-daemon/Makefile.am
parent4de1dfb3b436075727bed0aed048c8a072d811f3 (diff)
systemd: add support for acquiring socket from systemd
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 0aac0fc..c406a62 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -1,7 +1,7 @@
# $Id$
#
# This file is part of avahi.
-#
+#
# avahi is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as
# published by the Free Software Foundation; either version 2 of the
@@ -53,6 +53,7 @@ avahi_daemon_SOURCES = \
static-hosts.c static-hosts.h \
ini-file-parser.c ini-file-parser.h \
setproctitle.c setproctitle.h \
+ sd-daemon.h sd-daemon.c \
../avahi-client/check-nss.c
avahi_daemon_CFLAGS = $(AM_CFLAGS) $(LIBDAEMON_CFLAGS) $(XML_CFLAGS)
@@ -63,7 +64,7 @@ ini_file_parser_test_SOURCES = \
ini-file-parser-test.c
ini_file_parser_test_CFLAGS = $(AM_CFLAGS)
-ini_file_parser_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-core/libavahi-core.la
+ini_file_parser_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-core/libavahi-core.la
pkgsysconf_DATA = \
avahi-daemon.conf \
@@ -163,3 +164,7 @@ xmllint:
install-data-local:
test -z "$(localstatedir)/run" || $(mkdir_p) "$(DESTDIR)$(localstatedir)/run"
+
+update-systemd:
+ curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.c > sd-daemon.c
+ curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.h > sd-daemon.h