summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-07-30 14:03:22 +0000
committerLennart Poettering <lennart@poettering.net>2005-07-30 14:03:22 +0000
commit3c4e0db3a35b851398eac7c598009e42e3ea7843 (patch)
tree07c39a10d0e53a46437b71fda31331af5c369f88 /avahi-daemon/Makefile.am
parent5b5d01cabfcca8cd50d053aa56714cb0eb2f611e (diff)
* hide generate init scripts from SVN
* DBUS: implement introspection for Server object * fix avahi-daemon build (missing stdio.h inclusion) git-svn-id: file:///home/lennart/svn/public/avahi/trunk@199 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index ed231a6..f152984 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -63,7 +63,8 @@ service_DATA = \
pkgdata_DATA = \
avahi-service.dtd
-EXTRA_DIST = avahi-service.dtd avahi-daemon.conf example.service dbus-test.py
+EXTRA_DIST = avahi-service.dtd avahi-daemon.conf example.service dbus-test.py Server.introspect server-introspect-xml.c
+BUILT_SOURCES = server-introspect-xml.c
if ENABLE_DBUS
avahi_daemon_SOURCES += dbus-protocol.c dbus-protocol.h
@@ -80,3 +81,7 @@ avahi_daemon_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/
xmllint:
xmllint --noout --valid example.service
xmllint --noout --valid Server.introspect
+ xmllint --noout --valid EntryGroup.introspect
+
+server-introspect-xml.c: Server.introspect
+ python embedd-file.py -s $< server_introspect_xml > $@