summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-30 21:22:05 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-30 21:22:05 +0000
commit5dcd0f6ff8458786206bace673263bcc04b53edf (patch)
tree3c24a43636ec7ce17a4d61fa1718ea5249ab947a /avahi-daemon/Makefile.am
parentaedd4e87362371d83dd64d0bfb03ea3e5526607f (diff)
make use of setproctitle() to change the process title of the daemon processes. This is especially useful to distuingish the main daemon and the chroot() helper process.
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@908 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 0dadede..9819f56 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -50,7 +50,8 @@ avahi_daemon_SOURCES = \
main.c main.h \
simple-protocol.c simple-protocol.h \
static-services.c static-services.h \
- ini-file-parser.c ini-file-parser.h
+ ini-file-parser.c ini-file-parser.h \
+ setproctitle.c setproctitle.h
avahi_daemon_CFLAGS = $(AM_CFLAGS) $(LIBDAEMON_CFLAGS)
avahi_daemon_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-core/libavahi-core.la $(LIBDAEMON_LIBS) -lexpat