summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-06-17 12:37:47 +0000
committerTrent Lloyd <lathiat@bur.st>2005-06-17 12:37:47 +0000
commit652139e9eeb4e2c50b9d1b71de01721a81a239e6 (patch)
tree2ce22cc7df3794b52d7db932eaabb5c9260780b7 /avahi-daemon/Makefile.am
parent16b19ffe5fa3b111bedf5342bc6c08de5bf6d4ad (diff)
* Split out the dbus stuff in the daemon to a separate file so it can be built conditionally
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@118 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 3d01d5b..f90b16d 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -24,14 +24,15 @@ AM_LDADD=-lexpat
AM_CFLAGS+=$(GLIB20_CFLAGS)
AM_LDADD+=$(GLIB20_LIBS)
+if ENABLE_DBUS
# DBUS
AM_CFLAGS+=$(DBUS_CFLAGS)
AM_LDADD+=$(DBUS_LIBS)
+endif
# This cool debug trap works on i386/gcc only
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
-if ENABLE_DBUS
bin_PROGRAMS = \
avahi
@@ -40,9 +41,12 @@ avahi_SOURCES = \
simple-protocol.c simple-protocol.h \
static-services.c static-services.h
+if ENABLE_DBUS
+avahi_SOURCES += dbus-protocol.c dbus-protocol.h
+endif
+
avahi_CFLAGS = $(AM_CFLAGS)
avahi_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
-endif
xmllint:
xmllint --noout --valid example.service