summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-06-30 22:55:20 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-06-30 22:55:20 +0000
commitaab15b8d9a9d5d869659915c3d0995929ae4179b (patch)
tree4a2bf6387e835d17e94ad28b9beaf5a2992e401d /avahi-daemon/Makefile.am
parentb7ca2e3b1fe5d7a4134728aa8cc88d9fb363b77c (diff)
* moved AVAHI_RUNTIME_DIR and AVAHI_SOCKET in configure.ac
* avahi-dnsconf and avahi use them for pid and socket file * check that ${prefix} is fully expanded in config.h * cosmetic changes in configure.ac git-svn-id: file:///home/lennart/svn/public/avahi/trunk@158 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 4c943e4..6ad5421 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -19,14 +19,13 @@
pkgsysconfdir=$(sysconfdir)/avahi
servicedir=$(pkgsysconfdir)/services
-dbusservicedir=$(DBUS_SYS_DIR)
AM_CFLAGS= \
-I$(top_srcdir) \
-D_GNU_SOURCE \
-DAVAHI_SERVICE_DIRECTORY=\"$(servicedir)\" \
- -DAVAHI_CONFIG_FILE=\"$(pkgsysconfdir)/avahi.conf\" \
- -DAVAHI_RUNTIME_DIR=\"$(localstatedir)/run/avahi\"
+ -DAVAHI_CONFIG_FILE=\"$(pkgsysconfdir)/avahi.conf\"
+
AM_LDADD=-lexpat
@@ -67,6 +66,7 @@ pkgdata_DATA = \
if ENABLE_DBUS
avahi_SOURCES += dbus-protocol.c dbus-protocol.h
+dbusservicedir = $(DBUS_SYS_DIR)
dbusservice_DATA = avahi-dbus.conf
EXTRA_DIST = $(dbusservice_DATA)