summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-06-26 03:55:49 +0200
committerLennart Poettering <lennart@poettering.net>2010-06-26 03:55:49 +0200
commitd77d1a036bc186878e804736f02cb38eef450e1d (patch)
treee23ff153ce587cd188903b6f11d3345d023f5a98 /avahi-daemon/Makefile.am
parente8ff04008dded22c9d9744b1bc294b6929ec23c0 (diff)
dbus: move interfaces into standard D-Bus interfaces directory
http://avahi.org/ticket/268
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am41
1 files changed, 14 insertions, 27 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index c21e30f..04843fb 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -25,7 +25,7 @@ if HAVE_XML
pkgsysconfdir=$(sysconfdir)/avahi
servicedir=$(pkgsysconfdir)/services
-introspectiondir=$(pkgdatadir)/introspection
+introspectiondir=$(datadir)/dbus-1/interfaces
AM_CFLAGS+= \
-DAVAHI_DAEMON_RUNTIME_DIR=\"$(avahi_runtime_dir)/avahi-daemon/\" \
@@ -68,11 +68,11 @@ pkgsysconf_DATA = \
avahi-daemon.conf \
hosts
-service_DATA = \
+dist_service_DATA = \
ssh.service \
sftp-ssh.service
-pkgdata_DATA = \
+dist_pkgdata_DATA = \
avahi-service.dtd
if ENABLE_CHROOT
@@ -116,39 +116,26 @@ avahi_daemon_LDADD += \
avahi_daemon_CFLAGS += $(DBUS_CFLAGS) -DDBUS_SYSTEM_BUS_DEFAULT_ADDRESS=\"$(DBUS_SYSTEM_BUS_DEFAULT_ADDRESS)\"
-dbusservice_DATA = avahi-dbus.conf
+dist_dbusservice_DATA = avahi-dbus.conf
-introspection_DATA = \
- Server.introspect \
- EntryGroup.introspect \
- DomainBrowser.introspect \
- ServiceTypeBrowser.introspect \
- ServiceBrowser.introspect \
- ServiceResolver.introspect \
- AddressResolver.introspect \
- HostNameResolver.introspect \
- RecordBrowser.introspect
+dist_introspection_DATA = \
+ org.freedesktop.Avahi.Server.xml \
+ org.freedesktop.Avahi.EntryGroup.xml \
+ org.freedesktop.Avahi.DomainBrowser.xml \
+ org.freedesktop.Avahi.ServiceTypeBrowser.xml \
+ org.freedesktop.Avahi.ServiceBrowser.xml \
+ org.freedesktop.Avahi.ServiceResolver.xml \
+ org.freedesktop.Avahi.AddressResolver.xml \
+ org.freedesktop.Avahi.HostNameResolver.xml \
+ org.freedesktop.Avahi.RecordBrowser.xml
endif
endif
endif
EXTRA_DIST = \
- avahi-service.dtd \
avahi-daemon.conf \
example.service \
- avahi-dbus.conf \
- Server.introspect \
- EntryGroup.introspect \
- DomainBrowser.introspect \
- ServiceTypeBrowser.introspect \
- ServiceBrowser.introspect \
- ServiceResolver.introspect \
- AddressResolver.introspect \
- HostNameResolver.introspect \
- RecordBrowser.introspect \
- ssh.service \
- sftp-ssh.service \
hosts \
example.service \
introspect.dtd \