summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-01-20 22:56:11 +0000
committerLennart Poettering <lennart@poettering.net>2006-01-20 22:56:11 +0000
commite614891d38cae63957d0bfc00d34ecdbad4f8322 (patch)
tree55336f0efd0999e0ed17bec823470844587fe65c /avahi-daemon/Makefile.am
parent7d59b3ba820c19488b0637b5dd9798deb68fb0dc (diff)
* add new API function avahi_nss_support()
* add new DBUS method Server.IsNSSSupportAvailable() * add support for IsNSSSupportAvailabke() to avahi-bookmarks git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1092 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index ffcfa58..e1d64a4 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -100,12 +100,17 @@ avahi_daemon_SOURCES += \
dbus-sync-host-name-resolver.c \
dbus-sync-service-resolver.c \
dbus-record-browser.c \
- ../avahi-common/dbus.c ../avahi-common/dbus.h \
- ../avahi-common/dbus-watch-glue.c ../avahi-common/dbus-watch-glue.h
+ ../avahi-common/dbus.c ../avahi-common/dbus.h \
+ ../avahi-common/dbus-watch-glue.c ../avahi-common/dbus-watch-glue.h \
+ ../avahi-client/check-nss.c
avahi_daemon_LDADD += \
$(DBUS_LIBS)
+if HAVE_DLOPEN
+avahi_daemon_LDADD += -ldl
+endif
+
avahi_daemon_CFLAGS += $(DBUS_CFLAGS)
dbusservice_DATA = avahi-dbus.conf