summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-11-24 02:03:21 +0000
committerLennart Poettering <lennart@poettering.net>2005-11-24 02:03:21 +0000
commitef51c776fa80e67b84e2a6d48829f9040ac76c20 (patch)
tree613d6ec4b3af4a3ec9e129c5587fd6b4258afcd2 /avahi-daemon/Makefile.am
parentbe4aaeb485d31dee095b0c9c90e6b79333bc0e21 (diff)
don't build static library for dbus-watch-glue and the like, instead compile the sources directly where it is needed
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1028 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 23f5a97..246bd90 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -98,10 +98,11 @@ avahi_daemon_SOURCES += \
dbus-sync-address-resolver.c \
dbus-sync-host-name-resolver.c \
dbus-sync-service-resolver.c \
- dbus-record-browser.c
-
+ dbus-record-browser.c \
+ ../avahi-common/dbus.c ../avahi-common/dbus.h \
+ ../avahi-common/dbus-watch-glue.c ../avahi-common/dbus-watch-glue.h
+
avahi_daemon_LDADD += \
- ../avahi-common/libdbus-common.la \
$(DBUS_LIBS)
avahi_daemon_CFLAGS += $(DBUS_CFLAGS)