summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-22 23:20:05 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-22 23:20:05 +0000
commitfe13f31ab613736d5fd6e614a1d4690028753e08 (patch)
treeac516a9da287303802f079511352f8ee61033d86 /avahi-daemon/Makefile.am
parentf8cc6a9085484ca90baa3967cc9ac440b8b309b6 (diff)
* Add introspection data for new resolver interfaces
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@403 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 32831ba..f1f0d51 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -88,7 +88,10 @@ introspection_DATA = \
EntryGroup.introspect \
DomainBrowser.introspect \
ServiceTypeBrowser.introspect \
- ServiceBrowser.introspect
+ ServiceBrowser.introspect \
+ ServiceResolver.introspect \
+ AddressResolver.introspect \
+ HostNameResolver.introspect
endif
endif
@@ -112,8 +115,6 @@ EXTRA_DIST = \
xmllint:
xmllint --noout --valid example.service
- xmllint --noout --valid Server.introspect
- xmllint --noout --valid EntryGroup.introspect
- xmllint --noout --valid DomainBrowser.introspect
- xmllint --noout --valid ServiceTypeBrowser.introspect
- xmllint --noout --valid ServiceBrowser.introspect
+ for F in $(introspection_DATA) ; do \
+ xmllint --noout --valid $$F ; \
+ done