summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
authorJames Willcox <snopr@snorp.net>2005-09-14 05:05:04 +0000
committerJames Willcox <snopr@snorp.net>2005-09-14 05:05:04 +0000
commit217046a958569ecdc2bb72997b157de011e17c9d (patch)
tree0cc2857aade6711bbba117f0f500e62f358e9e11 /avahi-sharp/Makefile.am
parent714098f62225c0bfd09c2e146c4db49076b87cdb (diff)
add docs for avahi-sharp
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@582 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index d361221..c0866df 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -20,7 +20,13 @@
ASSEMBLY = avahi-sharp.dll
CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
-EXTRA_DIST = $(AVAHISOURCES) avahi.snk avahi-sharp.dll.config
+EXTRA_DIST = \
+ $(AVAHISOURCES) \
+ avahi.snk \
+ avahi-sharp.dll.config \
+ avahi-sharp-docs.source \
+ en/*.xml \
+ en/*/*.xml
AVAHISOURCES = \
$(srcdir)/AssemblyInfo.cs \
@@ -41,6 +47,18 @@ $(ASSEMBLY): $(AVAHISOURCES)
if HAVE_MONO
all: $(ASSEMBLY)
+if HAVE_MONODOC
+update-docs: $(ASSEMBLY)
+ $(MONODOCER) -assembly:$(ASSEMBLY) -path:en
+
+avahi-sharp-docs.zip: $(srcdir)/en/*/*
+ $(MDASSEMBLER) --out avahi-sharp-docs --ecma $(srcdir)/en
+
+docdir = $(MONODOC_DIR)
+doc_DATA = avahi-sharp-docs.zip avahi-sharp-docs.tree avahi-sharp-docs.source
+
+endif
+
install-data-hook: $(ASSEMBLY)
$(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)