summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
authorJames Willcox <snopr@snorp.net>2005-09-25 23:22:36 +0000
committerJames Willcox <snopr@snorp.net>2005-09-25 23:22:36 +0000
commita24befc8bf02cce7c4a2ee81f0a87d5bae83df1b (patch)
treefe46f7ffca33c6407e1b292c7636f5cfee469a8a /avahi-sharp/Makefile.am
parentfbd822ec8fa4575a61e81e2ecf2c4e6f8266a0ff (diff)
automatically figure out the dlnames for the unmanaged libs
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@625 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index 12947f0..4095eca 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -19,7 +19,7 @@
ASSEMBLY = avahi-sharp.dll
-CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
+CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb $(ASSEMBLY).config
AVAHISOURCES = \
$(srcdir)/AddressResolver.cs \
@@ -38,17 +38,22 @@ EXTRA_DIST = \
$(AVAHISOURCES) \
$(srcdir)/AvahiTest.cs \
$(srcdir)/avahi.snk \
- $(srcdir)/avahi-sharp.dll.config \
+ $(srcdir)/$(ASSEMBLY).config \
$(srcdir)/avahi-sharp-docs.source \
$(srcdir)/en/*.xml \
- $(srcdir)/en/*/*.xml
-
+ $(srcdir)/en/*/*.xml \
+ $(srcdir)/gencfg.sh
$(ASSEMBLY): $(AVAHISOURCES)
mcs -keyfile:$(srcdir)/avahi.snk -target:library -out:$@ -debug $(AVAHISOURCES) -r:Mono.Posix
+
+$(ASSEMBLY).config: $(ASSEMBLY).config.in
+ $(srcdir)/gencfg.sh $(top_builddir)/avahi-client/libavahi-client.la \
+ $(top_builddir)/avahi-common/libavahi-common.la < $< > $@
+
if HAVE_MONO
-all: $(ASSEMBLY)
+all: $(ASSEMBLY) $(ASSEMBLY).config
if HAVE_MONODOC
update-docs: $(ASSEMBLY)