summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
authorJames Willcox <snopr@snorp.net>2005-09-09 19:29:47 +0000
committerJames Willcox <snopr@snorp.net>2005-09-09 19:29:47 +0000
commita72903f1b332e1910971ae06d3923eea7796a8e9 (patch)
tree0c5c04337f5c363816b199ae07c9e2718be89905 /avahi-sharp/Makefile.am
parent92ab95ea1859cafa5cc80de4811e4cc438ff6f88 (diff)
add pkg-config file, and AssemblyInfo
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@543 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index ffee4cd..e912715 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -3,9 +3,10 @@
ASSEMBLY = avahi-sharp.dll
CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
-EXTRA_DIST = $(AVAHISOURCES) avahi.snk
+EXTRA_DIST = $(AVAHISOURCES) avahi.snk avahi-sharp.pc.in
AVAHISOURCES = \
+ $(srcdir)/AssemblyInfo.cs \
$(srcdir)/AddressResolver.cs \
$(srcdir)/Client.cs \
$(srcdir)/ClientException.cs \
@@ -18,11 +19,19 @@ AVAHISOURCES = \
$(srcdir)/Utility.cs
$(ASSEMBLY): $(AVAHISOURCES)
- mcs -keyfile:$(srcdir)/avahi.snk -target:library -o $@ -debug $(AVAHISOURCES) -r:Mono.Posix
+ mcs -keyfile:$(srcdir)/avahi.snk -target:library -out:$@ -debug $(AVAHISOURCES) -r:Mono.Posix
if HAVE_MONO
all: $(ASSEMBLY)
+pkgcfgdir = $(libdir)/pkgconfig
+pkgcfg_DATA = avahi-sharp.pc
+
+avahi-sharp.pc: avahi-sharp.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@libdir\@,$(libdir),g' $< > $@
+
install-data-hook:
$(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
endif