summaryrefslogtreecommitdiffstats
path: root/avahi-utils/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-05 18:59:21 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-05 18:59:21 +0000
commit0632e854728e8e64552ae08f90852d4a2658539e (patch)
tree0fab7d52e01da7ab9b81b8409dcf70cceb7d2852 /avahi-utils/Makefile.am
parentd76069e946b4e89c828c96340677e40f583080c9 (diff)
* add proper error codes and patch everything to make use of it
* parameter validity checkin in all user visible functions of libavahi-core * two new python tools/examples avahi-resolve-host-name and avahi-resolve-address git-svn-id: file:///home/lennart/svn/public/avahi/trunk@238 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-utils/Makefile.am')
-rw-r--r--avahi-utils/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
index 90b908c..144ee12 100644
--- a/avahi-utils/Makefile.am
+++ b/avahi-utils/Makefile.am
@@ -24,14 +24,18 @@ pythonscripts = \
avahi-publish-service \
avahi-dump-all \
avahi-discover \
- avahi-bookmarks
+ avahi-bookmarks \
+ avahi-resolve-host-name \
+ avahi-resolve-address
EXTRA_DIST = \
avahi-publish-address.in \
avahi-publish-service.in \
avahi-dump-all.in \
avahi-discover.in \
- avahi-bookmarks.in
+ avahi-bookmarks.in \
+ avahi-resolve-host-name.in \
+ avahi-resolve-address.in
if HAVE_PYTHON
bin_SCRIPTS = $(pythonscripts)
@@ -58,4 +62,12 @@ avahi-bookmarks: avahi-bookmarks.in
sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
chmod +x $@
+avahi-resolve-host-name: avahi-resolve-host-name.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
+ chmod +x $@
+
+avahi-resolve-address: avahi-resolve-address.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
+ chmod +x $@
+
CLEANFILES = $(pythonscripts)