summaryrefslogtreecommitdiffstats
path: root/avahi-utils/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-26 21:27:40 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-26 21:27:40 +0000
commit854f901f491ccda79aee11edc3d59109cb229d28 (patch)
treecfaf27b1e11af5c7504e6825e205d9d1ed2c6035 /avahi-utils/Makefile.am
parent740bc001fb647255709b5385d5a8a19781722097 (diff)
* avahi-utils: replace python avahi-browse with a version written in C.
* remove -Wunused from GCC command line and use "unused" attribute instead * remove AVAHI_CLIENT_S_FAILURE and AVAHI_CLIENT_S_INVALID since these event's are never forwarded to the client anyway * make use of AVAHI_GCC_NORETURN * really send eror code with StateChange DBUS signals * ignore EINTR in avahi_simple_poll_loop() git-svn-id: file:///home/lennart/svn/public/avahi/trunk@879 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-utils/Makefile.am')
-rw-r--r--avahi-utils/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
index 1e10f25..0c5b711 100644
--- a/avahi-utils/Makefile.am
+++ b/avahi-utils/Makefile.am
@@ -20,7 +20,6 @@
EXTRA_DIST = \
avahi-publish-address.in \
avahi-publish-service.in \
- avahi-browse.in \
avahi-bookmarks.in \
avahi-resolve-host-name.in \
avahi-resolve-address.in \
@@ -36,7 +35,6 @@ if HAVE_PYGTK
pythonscripts = \
avahi-publish-address \
avahi-publish-service \
- avahi-browse \
avahi-bookmarks \
avahi-resolve-host-name \
avahi-resolve-address \
@@ -62,10 +60,6 @@ avahi-publish-service: avahi-publish-service.in
sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
chmod +x $@
-avahi-browse: avahi-browse.in
- sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
- chmod +x $@
-
avahi-bookmarks: avahi-bookmarks.in
sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
chmod +x $@
@@ -84,3 +78,13 @@ CLEANFILES = $(pythonscripts) $(desktop_DATA)
endif
endif
endif
+
+if HAVE_DBUS
+
+bin_PROGRAMS = avahi-browse
+
+avahi_browse_SOURCES = avahi-browse.c sigint.c
+avahi_browse_CFLAGS = $(AM_CFLAGS)
+avahi_browse_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
+
+endif