summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-12-07 16:03:06 +0100
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-12-07 16:03:06 +0100
commit01905caa58178302d2bc910893e09eeca81ef320 (patch)
tree3a1c7d21f73a784ce82b8d17c1cd4447131af0e6 /configure.ac
parent14cfd1874f5ecfed1b51fe3421da7f5c7715ac6a (diff)
Don't enable PIC code for all compilation.
libtool will take care of enabling PIC code whenever necessary, users of PIE-based systems, for randomised processes address will have -fPIE anyway.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c075a68..4826a60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -299,7 +299,7 @@ test_gcc_flag() {
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
- DESIRED_FLAGS="-Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline -fPIC"
+ DESIRED_FLAGS="-Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline"
if test "x$HAVE_NETLINK" = "xyes" ; then
# Test whether rtnetlink.h can be included when compiled with -std=c99