summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-07-10 22:41:39 +0000
committerLennart Poettering <lennart@poettering.net>2007-07-10 22:41:39 +0000
commit9225e01a984f730e6b2755a37e83c7ca4ee601cb (patch)
tree3f7639f44a5664b6f64707ee2132df3b2bcd195c /configure.ac
parenta2243229bc2fb20b0c010b3830f79ef2d2383ccd (diff)
Add FreeBSD kqueue support for watching for configuration file changes, much the same way we currently have for Linux with inotify. (Patch supplied by marcus, but autoconf check reversed, re #149)
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1495 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8352d1b..0c205c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -384,6 +384,15 @@ if test "x$have_inotify" = "xyes" ; then
AC_DEFINE([HAVE_INOTIFY], 1, [Enable Linux inotify() usage])
fi
+have_kqueue=yes
+AC_CHECK_FUNCS([kqueue],,have_kqueue=no)
+
+AM_CONDITIONAL(HAVE_KQUEUE, test "x$have_kqueue" = "xyes")
+
+if test "x$have_kqueue" = "xyes" ; then
+ AC_DEFINE([HAVE_KQUEUE], 1, [Enable BSD kqueue() usage])
+fi
+
# Check for pkg-config manually first, as if its not installed the
# PKG_PROG_PKG_CONFIG macro won't be defined.
AC_CHECK_PROG(have_pkg_config, pkg-config, yes, no)