summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-06-27 01:36:25 +0200
committerLennart Poettering <lennart@poettering.net>2010-06-27 01:36:25 +0200
commited11c6a4d4da379ff9ebccb7a0340e64232efabb (patch)
tree8fa5cea77c6a149f0efdc8536913ebcc28571da2 /configure.ac
parent5b0187292d95c991c37efeeaf36fac9628dae5dc (diff)
build-sys: install systemd service files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d4f45ea..42d7d22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1067,6 +1067,15 @@ AC_ARG_ENABLE(compat-howl,
AM_CONDITIONAL([ENABLE_COMPAT_HOWL], [test "x$ENABLE_COMPAT_HOWL" = "xyes"])
+#
+# systemd
+#
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [],
+ [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
# ==========================================================================
AC_CONFIG_FILES([
@@ -1150,6 +1159,7 @@ echo "
Enable chroot(): ${enable_chroot}
Enable Linux inotify: ${have_inotify}
Enable stack-smashing protection: ${enable_ssp}
+ systemd unit directory: ${with_systemdsystemunitdir}
"
BUILD_DAEMON="no (You need libdaemon and expat/bsdxml!)"