summaryrefslogtreecommitdiffstats
path: root/initscript/fedora/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-22 21:23:02 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-22 21:23:02 +0000
commit2a2ee0be70b99239f2cf99ea5b663eda965599f8 (patch)
tree4ac2d3edc774099855cd58b6d83c2d3e2c963ae4 /initscript/fedora/Makefile.am
parent80ffb739edcbcdc2a22bfed71b7913213392f6ff (diff)
Add init script support for fedora from Alexander Larsson
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@838 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'initscript/fedora/Makefile.am')
-rw-r--r--initscript/fedora/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/initscript/fedora/Makefile.am b/initscript/fedora/Makefile.am
new file mode 100644
index 0000000..e18f0f6
--- /dev/null
+++ b/initscript/fedora/Makefile.am
@@ -0,0 +1,34 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = $(sysconfdir)/init.d
+
+EXTRA_DIST = avahi-daemon.in avahi-dnsconfd.in
+
+initd_SCRIPTS = avahi-daemon avahi-dnsconfd
+
+CLEANFILES = avahi-daemon avahi-dnsconfd
+
+avahi-daemon: avahi-daemon.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+avahi-dnsconfd: avahi-dnsconfd.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@