summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-06 13:11:18 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-06 13:11:18 +0000
commit61eb92b1ba30fd4da9be7e9dc9714125c1576cca (patch)
treea413b6a7863f1f273650d40e15c491a079109d1c /man/Makefile.am
parent0b5a3c8d2caf8a985c5bdd7965c36a0aeafb54aa (diff)
preliminary mn page work
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@247 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..2d382ee
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,48 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+man_MANS = avahi-browse.1
+
+noinst_DATA = \
+ avahi-browse.1.xml
+
+EXTRA_DIST = \
+ $(man_MANS) \
+ avahi-browse.1.xml.in \
+ xmltoman.css \
+ xmltoman.xsl \
+ xmltoman.dtd
+
+CLEANFILES = \
+ $(noinst_DATA)
+
+avahi-browse.1.xml: avahi-browse.1.xml.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
+ -e 's,@sbindir\@,$(sbindir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+if USE_XMLTOMAN
+
+CLEANFILES += $(man_MANS)
+
+avahi-browse.1: avahi-browse.1.xml Makefile
+ xmltoman $< > $@
+
+endif