summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-02-14 22:13:30 +0000
committerLennart Poettering <lennart@poettering.net>2006-02-14 22:13:30 +0000
commit668eb7b3e832082dbf80a5e77a84de140c3cd571 (patch)
tree6ce8e4fd939d1628e42eb82cf5ff4a9a9474758c /man/Makefile.am
parentb7758b00b5f52f9c3c4fd986b9a14d4980640fa0 (diff)
add man page for /etc/avahi/hosts and modify other man pages to refer to it
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1138 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index f16e8e1..3b90835 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -27,7 +27,8 @@ man_MANS = \
avahi-dnsconfd.8 \
avahi-daemon.conf.5 \
avahi-dnsconfd.action.8 \
- avahi.service.5
+ avahi.service.5 \
+ avahi.hosts.5
noinst_DATA = \
avahi-browse.1.xml \
@@ -39,7 +40,8 @@ noinst_DATA = \
avahi-dnsconfd.8.xml \
avahi-daemon.conf.5.xml \
avahi-dnsconfd.action.8.xml \
- avahi.service.5.xml
+ avahi.service.5.xml \
+ avahi.hosts.5.xml
CLEANFILES = \
$(noinst_DATA)
@@ -105,6 +107,10 @@ avahi.service.5.xml: avahi.service.5.xml.in Makefile
-e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+avahi.hosts.5.xml: avahi.hosts.5.xml.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
if USE_XMLTOMAN
@@ -140,6 +146,8 @@ avahi-dnsconfd.action.8: avahi-dnsconfd.action.8.xml Makefile
avahi.service.5: avahi.service.5.xml Makefile
xmltoman $< > $@
+avahi.hosts.5: avahi.hosts.5.xml Makefile
+ xmltoman $< > $@
xmllint: $(noinst_DATA)
for f in $(noinst_DATA) ; do \
@@ -162,6 +170,7 @@ EXTRA_DIST = \
avahi-daemon.conf.5.xml.in \
avahi-dnsconfd.action.8.xml.in \
avahi.service.5.xml.in \
+ avahi.hosts.5.xml.in \
xmltoman.css \
xmltoman.xsl \
xmltoman.dtd