summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-07 19:24:44 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-07 19:24:44 +0000
commit88a99a094e561b6c87404f4999e61e7b9ed754f6 (patch)
tree1827ae949fe368557892bd4037556e99bc501fee /man/Makefile.am
parenta9e118b82c39b12695575229934af435058668a5 (diff)
add man page for avahi-daemon.conf
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@260 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 39ebcd9..946a15f 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -22,7 +22,8 @@ servicedir=$(pkgsysconfdir)/services
man_MANS = \
avahi-daemon.8 \
- avahi-dnsconfd.8
+ avahi-dnsconfd.8 \
+ avahi-daemon.conf.5
if HAVE_PYTHON
@@ -46,7 +47,8 @@ noinst_DATA = \
avahi-daemon.8.xml \
avahi-discover.1.xml \
avahi-bookmarks.1.xml \
- avahi-dnsconfd.8.xml
+ avahi-dnsconfd.8.xml \
+ avahi-daemon.conf.5.xml
EXTRA_DIST = \
$(man_MANS) \
@@ -59,6 +61,7 @@ EXTRA_DIST = \
avahi-discover.1.xml.in \
avahi-bookmarks.1.xml.in \
avahi-dnsconfd.8.xml.in \
+ avahi-daemon.5.conf.xml.in \
xmltoman.css \
xmltoman.xsl \
xmltoman.dtd
@@ -105,6 +108,11 @@ avahi-dnsconfd.8.xml: avahi-dnsconfd.8.xml.in Makefile
-e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+avahi-daemon.conf.5.xml: avahi-daemon.conf.5.xml.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
if USE_XMLTOMAN
@@ -137,4 +145,7 @@ avahi-bookmarks.1: avahi-bookmarks.1.xml Makefile
avahi-dnsconfd.8: avahi-dnsconfd.8.xml Makefile
xmltoman $< > $@
+avahi-daemon.conf.5: avahi-daemon.conf.5.xml Makefile
+ xmltoman $< > $@
+
endif