summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-07 19:53:39 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-07 19:53:39 +0000
commitd66b47f2d2d6dfcf40faad7d4c94d46ac405ebf0 (patch)
tree4ae3b9999a08ecc6825c2518a428862ce32f2fcd /man/Makefile.am
parentc1c187ff2eb513734214b1d814a57aa929ddf70f (diff)
* add man page for avahi-dnsconfd.action
* fix xmltoman DTD git-svn-id: file:///home/lennart/svn/public/avahi/trunk@263 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 4037bee..f9d226a 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -23,7 +23,8 @@ servicedir=$(pkgsysconfdir)/services
man_MANS = \
avahi-daemon.8 \
avahi-dnsconfd.8 \
- avahi-daemon.conf.5
+ avahi-daemon.conf.5 \
+ avahi-dnsconfd.action.8
if HAVE_PYTHON
@@ -48,7 +49,8 @@ noinst_DATA = \
avahi-discover.1.xml \
avahi-bookmarks.1.xml \
avahi-dnsconfd.8.xml \
- avahi-daemon.conf.5.xml
+ avahi-daemon.conf.5.xml \
+ avahi-dnsconfd.action.8.xml
EXTRA_DIST = \
$(man_MANS) \
@@ -62,6 +64,7 @@ EXTRA_DIST = \
avahi-bookmarks.1.xml.in \
avahi-dnsconfd.8.xml.in \
avahi-daemon.conf.5.xml.in \
+ avahi-dnsconfd.action.8.xml.in \
xmltoman.css \
xmltoman.xsl \
xmltoman.dtd
@@ -113,6 +116,11 @@ avahi-daemon.conf.5.xml: avahi-daemon.conf.5.xml.in Makefile
-e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+avahi-dnsconfd.action.8.xml: avahi-dnsconfd.action.8.xml.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
if USE_XMLTOMAN
@@ -148,4 +156,12 @@ avahi-dnsconfd.8: avahi-dnsconfd.8.xml Makefile
avahi-daemon.conf.5: avahi-daemon.conf.5.xml Makefile
xmltoman $< > $@
+avahi-dnsconfd.action.8: avahi-dnsconfd.action.8.xml Makefile
+ xmltoman $< > $@
+
+xmllint: $(noinst_DATA)
+ for f in $(noinst_DATA) ; do \
+ xmllint --noout --valid "$$f" || exit 1 ; \
+ done
+
endif