summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-07 10:49:51 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-07 10:49:51 +0000
commitf5f30ed5cad14cc2543fdd47645513abd3c694e9 (patch)
tree7b4a31bfe04b2814c0b3678b553785d6d45a39d5 /man/Makefile.am
parentb2abf404e9d5b8f156f359c6ab0ee444ba61322e (diff)
add man page for avahi-daemon
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@256 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am39
1 files changed, 23 insertions, 16 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 1fa4723..bcc3d11 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -17,9 +17,15 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
-if HAVE_PYTHON
+pkgsysconfdir=$(sysconfdir)/avahi
+servicedir=$(pkgsysconfdir)/services
man_MANS = \
+ avahi-daemon.8
+
+if HAVE_PYTHON
+
+man_MANS += \
avahi-browse.1 \
avahi-publish-service.1 \
avahi-publish-address.1 \
@@ -33,7 +39,8 @@ noinst_DATA = \
avahi-publish-service.1.xml \
avahi-publish-address.1.xml \
avahi-resolve-address.1.xml \
- avahi-resolve-host-name.1.xml
+ avahi-resolve-host-name.1.xml \
+ avahi-daemon.8.xml
EXTRA_DIST = \
$(man_MANS) \
@@ -42,6 +49,7 @@ EXTRA_DIST = \
avahi-publish-address.1.xml.in \
avahi-resolve-address.1.xml.in \
avahi-resolve-host-name.1.xml.in \
+ avahi-daemon.8.xml.in \
xmltoman.css \
xmltoman.xsl \
xmltoman.dtd
@@ -50,32 +58,28 @@ CLEANFILES = \
$(noinst_DATA)
avahi-browse.1.xml: avahi-browse.1.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
- -e 's,@sbindir\@,$(sbindir),g' \
- -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
avahi-publish-service.1.xml: avahi-publish-service.1.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
- -e 's,@sbindir\@,$(sbindir),g' \
- -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
avahi-publish-address.1.xml: avahi-publish-address.1.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
- -e 's,@sbindir\@,$(sbindir),g' \
- -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
avahi-resolve-address.1.xml: avahi-resolve-address.1.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
- -e 's,@sbindir\@,$(sbindir),g' \
- -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
avahi-resolve-host-name.1.xml: avahi-resolve-host-name.1.xml.in Makefile
- sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
- -e 's,@sbindir\@,$(sbindir),g' \
+ sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+avahi-daemon.8.xml: avahi-daemon.8.xml.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@servicedir\@,$(servicedir),g' \
-e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
@@ -98,4 +102,7 @@ avahi-resolve-address.1: avahi-resolve-address.1.xml Makefile
avahi-resolve-host-name.1: avahi-resolve-host-name.1.xml Makefile
xmltoman $< > $@
+avahi-daemon.8: avahi-daemon.8.xml Makefile
+ xmltoman $< > $@
+
endif